jueves, 30 de mayo de 2013

Funciones Y y O en Excel

0 comentarios
Hoy veremos dos funciones muy útiles para combinar con la función SI de Excel. Se trata de la función Y y la función O.

Como ya vimos en el artículo sobre la función SI, utilizamos la fórmula condicional para comparar el contenido de una celda y de esta manera realizar una acción u otra en función de esa condición:

=SI(Condición;Valor_Si_Cumple;Valor_NO_Cumple)

Gracias a las funciones y y o, tenemos la posibilidad de poner más de un criterio de comparación, de manera que si utilizamos la función y integrada dentro de una función SI, le estaremos indicando que para que la fórmula sea verdadera, se tienen que cumplir todas las condiciones.

La estructura de la función y, es muy simple:

=y(condición1; condición2; condición3;...;condiciónN)

El resultado será verdadero si se cumplen todas las condiciones, si no dará un resultado falso. Si lo unimos a la función SI, esto nos quedaría de la siguiente manera:

=SI(y(A1>=5;A1<=10);"Apto";"No Apto")

En este ejemplo, vemos que hemos sustituido la parte de la condición por una función Y (que lleva más de una condición), de manera que estamos limitando el criterio de la función a un rango de números entre 5 y 10; fuera de ese rango el resultado sería falso y por tanto nos daría como resultado No Apto.

La función O en Excel, funciona exactamente de la misma manera, pero para que sea verdadero, solo se tiene que cumplir una de las condiciones:

=SI(o(A1>=18;A2="Estudiante");"Apto";"No Apto")


En este caso, solo con que se cumpla una de las dos condiciones, el resultado sería Apto; si ninguna de las dos condiciones se cumpliera, sería No Apto.

Espero que os ayude...
 

El Profe de Excel por Pablo Motos. Copyright 2013 All Rights Reserved