viernes, 11 de mayo de 2012

FUNCIONES LÓGICAS: FUNCIÓN SI

3 comentarios


Empezamos el repaso a las funciones lógicas y lo haremos con la fundamental para entender las funciones lógicas, la función SI. Las funciones lógicas tienen como finalidad realizar una acción en función de una condición.

La estructura de la fución SI es la siguiente:

 =SI(Prueba_logica;Valor_si_verdadero;Valor_si_falso)

Lo que realizará la función, será comprobará la condición que especifiquemos en el apartado "prueba_logica". Siempre especificaremos una comparación entre una celda y un valor u otra celda. Para ello, utilizaremos siempre los comparadores <, <=, >, >=, = o <> (diferente). Si se cumple la condición, realizará la acción especificada en "Valor_si_verdadero" y en caso de que no se cumple, realizaría la acción de "Valor_si_Falso".

Ejemplo:

=si(A1>=5;"Aprobado";"Suspendido") --> en este caso la función comprobará si el valor de la celda A1 es mayor o igual a 5. Si lo es, mostrará como resultado Aprobado. En caso contrario, es decir, sea menor a 5, el resultado sería Suspendido
Importante destacar que dentro de una función SI, siempre que hagamos referencia a texto, éste debe ir entre comillas.

Vamos a ver con un ejemplo gráfico el funcionamiento de la función SI:

Uso función SISupongamos tenemos un cuadro como el de la derecha, con el detalle de Ejecutivos de venta, las ventas realizadas así como el objetivo y queremos ver si cumplió o no con él.

En este caso necesitamos comparar si las ventas superan (o igualan) al objetivo.  Ventas >= Objetivo
Si efectivamente las Ventas superan el Objetivo (Ventas>=Objetivo es VERDADERO), queremos que la celda (de la columna D) nos muestre “Cumplió”.  Y, en caso que no se cumpla (es decir, Ventas>=Objetivo es FALSO), nos muestre “No cumplió”.

Ya tenemos entonces las tres partes:
·         La función lógica: Ventas>=Objetivos
·         Valor si Verdadero: Mostrar “Cumplió”
·         Valor si Falso: Mostrar “No cumplió”. 

La fórmula, para la celda D2 será entonces:
=SI(B2>=C2;”Cumplió”;”No Cumplió”)

Es totalmente equivalente escribirla de la forma:
=SI(B2<C2;”No Cumplió”;”Si Cumplió”) => SI las Ventas son menores al Objetivo entonces mostrar “No Cumplió”, en caso contrario (es decir, si es FALSA la comparación Ventas<Objetivo), mostrar “Sí Cumplió”).

En próximos Posts veremos como anidar 2 SI y juntar la función SI con la función Y y la función O. Espero que os sirva de ayuda. Cualquier problema no dudéis en comentarlo en el post.


 

El Profe de Excel por Pablo Motos. Copyright 2013 All Rights Reserved